AuthenticationHandler methods

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

AuthenticationHandler methods

Felix Meschberger-2
Hi all,

Currently the AuthenticationHandler interface defines the following methods:

   authenticate - extract credentials from request
   requestAuthentication - ask client for credentials
   dropAuthentication - forget about current credentials

The authenticate and requestAuthentication names are historic and date
back to some internal code at the time whether AuthenticationHandler did
not exist yet.

IMHO these names are not that good. And since we are defining new API
anyway, this might probaby be a good time to rename the methods.

I am thinking of the following replacements

   getCredentials - extract credentials from request
   requestCredentials - ask client for credentials
   dropCredentials - forget about current credentials

WDYT ?
Does this make sense ?
Are there better names ?
What about the interface names ?

Thanks and Regards
Felix
Reply | Threaded
Open this post in threaded view
|

RE: AuthenticationHandler methods

Mike Müller
> Currently the AuthenticationHandler interface defines the
> following methods:
>
>    authenticate - extract credentials from request
>    requestAuthentication - ask client for credentials
>    dropAuthentication - forget about current credentials
>
> The authenticate and requestAuthentication names are historic and date
> back to some internal code at the time whether
> AuthenticationHandler did
> not exist yet.
>
> IMHO these names are not that good. And since we are defining new API
> anyway, this might probaby be a good time to rename the methods.
>
> I am thinking of the following replacements
>
>    getCredentials - extract credentials from request
>    requestCredentials - ask client for credentials
>    dropCredentials - forget about current credentials
>
> WDYT ?
> Does this make sense ?
> Are there better names ?
> What about the interface names ?

What about "extractCredentials" to be very explicit instead of getCredentials.

best regards
mike
Reply | Threaded
Open this post in threaded view
|

Re: AuthenticationHandler methods

Felix Meschberger-2
Hi,

On 07.01.2010 22:32, Mike Müller wrote:

>> Currently the AuthenticationHandler interface defines the
>> following methods:
>>
>>    authenticate - extract credentials from request
>>    requestAuthentication - ask client for credentials
>>    dropAuthentication - forget about current credentials
>>
>> The authenticate and requestAuthentication names are historic and date
>> back to some internal code at the time whether
>> AuthenticationHandler did
>> not exist yet.
>>
>> IMHO these names are not that good. And since we are defining new API
>> anyway, this might probaby be a good time to rename the methods.
>>
>> I am thinking of the following replacements
>>
>>    getCredentials - extract credentials from request
>>    requestCredentials - ask client for credentials
>>    dropCredentials - forget about current credentials
>>
>> WDYT ?
>> Does this make sense ?
>> Are there better names ?
>> What about the interface names ?
>
> What about "extractCredentials" to be very explicit instead of getCredentials.

Yes, makes sense (and the javadoc also already starts with "Extracts
credential data ...." ;-) )

Regards
Felix

Reply | Threaded
Open this post in threaded view
|

Re: AuthenticationHandler methods

Carsten Ziegeler
Felix Meschberger wrote:

> Hi,
>
> On 07.01.2010 22:32, Mike Müller wrote:
>>> Currently the AuthenticationHandler interface defines the
>>> following methods:
>>>
>>>    authenticate - extract credentials from request
>>>    requestAuthentication - ask client for credentials
>>>    dropAuthentication - forget about current credentials
>>>
>>> The authenticate and requestAuthentication names are historic and date
>>> back to some internal code at the time whether
>>> AuthenticationHandler did
>>> not exist yet.
>>>
>>> IMHO these names are not that good. And since we are defining new API
>>> anyway, this might probaby be a good time to rename the methods.
>>>
>>> I am thinking of the following replacements
>>>
>>>    getCredentials - extract credentials from request
>>>    requestCredentials - ask client for credentials
>>>    dropCredentials - forget about current credentials
>>>
>>> WDYT ?
>>> Does this make sense ?
>>> Are there better names ?
>>> What about the interface names ?
>> What about "extractCredentials" to be very explicit instead of getCredentials.
>
> Yes, makes sense (and the javadoc also already starts with "Extracts
> credential data ...." ;-) )
>
Yepp, I think the name changes including extractCredentials make sense

Carsten

--
Carsten Ziegeler
[hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: AuthenticationHandler methods

Felix Meschberger-2
Hi,

I have renamed the methods now (consider the last build failure as
intermediate, because the HTTP Basic Authentication Handler fix does not
seem to have made it into the build).

I we decide to not rename, we can still switch back.

Regards
Felix

On 08.01.2010 08:42, Carsten Ziegeler wrote:

> Felix Meschberger wrote:
>> Hi,
>>
>> On 07.01.2010 22:32, Mike Müller wrote:
>>>> Currently the AuthenticationHandler interface defines the
>>>> following methods:
>>>>
>>>>    authenticate - extract credentials from request
>>>>    requestAuthentication - ask client for credentials
>>>>    dropAuthentication - forget about current credentials
>>>>
>>>> The authenticate and requestAuthentication names are historic and date
>>>> back to some internal code at the time whether
>>>> AuthenticationHandler did
>>>> not exist yet.
>>>>
>>>> IMHO these names are not that good. And since we are defining new API
>>>> anyway, this might probaby be a good time to rename the methods.
>>>>
>>>> I am thinking of the following replacements
>>>>
>>>>    getCredentials - extract credentials from request
>>>>    requestCredentials - ask client for credentials
>>>>    dropCredentials - forget about current credentials
>>>>
>>>> WDYT ?
>>>> Does this make sense ?
>>>> Are there better names ?
>>>> What about the interface names ?
>>> What about "extractCredentials" to be very explicit instead of getCredentials.
>>
>> Yes, makes sense (and the javadoc also already starts with "Extracts
>> credential data ...." ;-) )
>>
> Yepp, I think the name changes including extractCredentials make sense
>
> Carsten
>