Compatibility of Sling Pipes across different versions

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Compatibility of Sling Pipes across different versions

Tobias Lippert

Hi together,

 

we decide on our project to use Sling Pipes for Content Migration. We are using AEM 6.2, so we can only use Sling Pipes v0.0.10.

We are planning to build the pipes with groovy console on our local dev machines in AEM 6.3. Unfortunately, the Sling Pipes created with v0.0.10 are not fully supported in v2.0.2 or behave different when they are executed. Is anyone aware of that? E.g. instead of deleting only a property in v2.0.2, the whole jcr:content node was deleted in v0.0.10. Which method would you recommend building Sling Pipes for AEM 6.2? Is there a list stating which features are available across the different Sling Pipes versions?

 

Thank you in advance.

 

Kind regards

Tobias Lippert

 

Tobias Lippert

Georg-Brauchle-Ring 58

Junior Consultant

+49 (0)1622601569 (cell)

80992 Munich, Germany

Adobe. Make It an Experience.

[hidden email]

www.adobe.com

 

 

 

Sitz der Gesellschaft: München - HR Muenchen HRB 111 128 - Geschaeftsfuehrer: Christian Keim, Keith San Felipe

Reply | Threaded
Open this post in threaded view
|

Re: Compatibility of Sling Pipes across different versions

Nicolas Peltier-3
Hi Tobias,

Compatibility breaks happened with 0.x ->1.x and 1.x -> 2.x. Some are API based, some about pipes themselves.
The major one I remember from top of my head is with sling query that, from 2.x + is much more used [0]. 1.x brought pipe builder (used in groovy creation you talked about), and $ was bound to children, while now it’s bound to find (which feels closer to what we know of a $() operation).
To my knowledge Write pipe can’t delete a node though, or it’s a bug you should treat differently than the migration version. Other than that, pipes configuration (if pipe type exists) should work across different versions and your technique sounds good.
Why can’t you use 2.0.2 or some 1.x on 6.2? jackrabbit API? There have been many bug fixes since then…

Nicolas

[0] https://sling.apache.org/documentation/bundles/sling-pipes/readers.html#sling-query-pipes

From: Tobias Lippert <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Wednesday 2 May 2018 at 13:01
To: "[hidden email]" <[hidden email]>
Subject: Compatibility of Sling Pipes across different versions

Hi together,

we decide on our project to use Sling Pipes for Content Migration. We are using AEM 6.2, so we can only use Sling Pipes v0.0.10.
We are planning to build the pipes with groovy console on our local dev machines in AEM 6.3. Unfortunately, the Sling Pipes created with v0.0.10 are not fully supported in v2.0.2 or behave different when they are executed. Is anyone aware of that? E.g. instead of deleting only a property in v2.0.2, the whole jcr:content node was deleted in v0.0.10. Which method would you recommend building Sling Pipes for AEM 6.2? Is there a list stating which features are available across the different Sling Pipes versions?

Thank you in advance.

Kind regards
Tobias Lippert

[ttps://inside.corp.adobe.com/content/dam/brandcenter/images/image002.gif]

Tobias Lippert

Georg-Brauchle-Ring 58

Junior Consultant

+49 (0)1622601569 (cell)

80992 Munich, Germany

Adobe. Make It an Experience.

[hidden email]

www.adobe.com







Sitz der Gesellschaft: München - HR Muenchen HRB 111 128 - Geschaeftsfuehrer: Christian Keim, Keith San Felipe