Replace ujax: prefix to sling:

classic Classic list List threaded Threaded
37 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Replace ujax: prefix to sling:

Felix Meschberger-2
Hi all,

Currently names used by Sling are prefixed with sling: with the
exception of well known parameters of the ujax servlets. To get all
these prefixes in line I suggest we change the prefix used by ujax
parameters to sling:

WDYT ?

Regards
Felix


Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Tobias Bocanegra
doesn't the "Jax" refer to the mechanism how the form post is handled?
it would at least call it 'sjax'

regards, toby

On 3/10/08, Felix Meschberger <[hidden email]> wrote:

> Hi all,
>
>  Currently names used by Sling are prefixed with sling: with the
>  exception of well known parameters of the ujax servlets. To get all
>  these prefixes in line I suggest we change the prefix used by ujax
>  parameters to sling:
>
>  WDYT ?
>
>  Regards
>
> Felix
>
>


--
-----------------------------------------< [hidden email] >---
Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001 Basel
T +41 61 226 98 98, F +41 61 226 98 97
-----------------------------------------------< http://www.day.com >---

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

David Nuescheler-3
hi guys,

i think it is confusing to deal with all those technologies for a newbie.
everything from jackrabbit to sling to jcr to osgi to launchpad to ujax.
some of this complexity is not necessary and can be removed easily.
i think the ujax / sling distinction can definitely go. i would basically
recommend to replace ujax with sling throughout the code, this
particularly includes the js side, and would graduate ujax into the
sling js library, which makes perfect sense to me.

regarding r-u-microjax, and related acronyms, this was more making fun of
bad acronyms than anything else and i always hoped that someone
would come along with a better name, so i am more than happy to
just call it "sling".

regards,
david

On Mon, Mar 10, 2008 at 8:09 PM, Tobias Bocanegra
<[hidden email]> wrote:

> doesn't the "Jax" refer to the mechanism how the form post is handled?
>  it would at least call it 'sjax'
>
>  regards, toby
>
>
>
>  On 3/10/08, Felix Meschberger <[hidden email]> wrote:
>  > Hi all,
>  >
>  >  Currently names used by Sling are prefixed with sling: with the
>  >  exception of well known parameters of the ujax servlets. To get all
>  >  these prefixes in line I suggest we change the prefix used by ujax
>  >  parameters to sling:
>  >
>  >  WDYT ?
>  >
>  >  Regards
>  >
>  > Felix
>  >
>  >
>
>
>  --
>  -----------------------------------------< [hidden email] >---
>  Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001 Basel
>  T +41 61 226 98 98, F +41 61 226 98 97
>  -----------------------------------------------< http://www.day.com >---
>

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
David Nuescheler wrote:

> hi guys,
>
> i think it is confusing to deal with all those technologies for a newbie.
> everything from jackrabbit to sling to jcr to osgi to launchpad to ujax.
> some of this complexity is not necessary and can be removed easily.
> i think the ujax / sling distinction can definitely go. i would basically
> recommend to replace ujax with sling throughout the code, this
> particularly includes the js side, and would graduate ujax into the
> sling js library, which makes perfect sense to me.
>
+1

> regarding r-u-microjax, and related acronyms, this was more making fun of
> bad acronyms than anything else and i always hoped that someone
> would come along with a better name, so i am more than happy to
> just call it "sling".
>
Ah, this is the right time to throw in my "catapult" naming idea :)
(Some day someone will pick it up, I'm 100% sure...)

Carsten
--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
In reply to this post by David Nuescheler-3
On Tue, Mar 11, 2008 at 8:28 AM, David Nuescheler <[hidden email]> wrote:

> ...i would basically
>  recommend to replace ujax with sling throughout the code, this
>  particularly includes the js side, and would graduate ujax into the
>  sling js library, which makes perfect sense to me....

Agreed, makes sense.

-Bertrand

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
In reply to this post by Carsten Ziegeler
On Tue, Mar 11, 2008 at 8:30 AM, Carsten Ziegeler <[hidden email]> wrote:

> ... Ah, this is the right time to throw in my "catapult" naming idea :)
>  (Some day someone will pick it up, I'm 100% sure...)...

Sure. some day ;-)

-Bertrand

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Tobias Bocanegra
In reply to this post by David Nuescheler-3
>  i think it is confusing to deal with all those technologies for a newbie.
>  everything from jackrabbit to sling to jcr to osgi to launchpad to ujax.
>  some of this complexity is not necessary and can be removed easily.
>  i think the ujax / sling distinction can definitely go. i would basically
>  recommend to replace ujax with sling throughout the code, this
>  particularly includes the js side, and would graduate ujax into the
>  sling js library, which makes perfect sense to me.
>
>  regarding r-u-microjax, and related acronyms, this was more making fun of
>  bad acronyms than anything else and i always hoped that someone
>  would come along with a better name, so i am more than happy to
>  just call it "sling".
+1 ok for me

>
>  regards,
>
> david
>
>
>  On Mon, Mar 10, 2008 at 8:09 PM, Tobias Bocanegra
>  <[hidden email]> wrote:
>  > doesn't the "Jax" refer to the mechanism how the form post is handled?
>  >  it would at least call it 'sjax'
>  >
>  >  regards, toby
>  >
>  >
>  >
>  >  On 3/10/08, Felix Meschberger <[hidden email]> wrote:
>  >  > Hi all,
>  >  >
>  >  >  Currently names used by Sling are prefixed with sling: with the
>  >  >  exception of well known parameters of the ujax servlets. To get all
>  >  >  these prefixes in line I suggest we change the prefix used by ujax
>  >  >  parameters to sling:
>  >  >
>  >  >  WDYT ?
>  >  >
>  >  >  Regards
>  >  >
>  >  > Felix
>  >  >
>  >  >
>  >
>  >
>  >  --
>  >  -----------------------------------------< [hidden email] >---
>  >  Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001 Basel
>  >  T +41 61 226 98 98, F +41 61 226 98 97
>  >  -----------------------------------------------< http://www.day.com >---
>  >
>


--
-----------------------------------------< [hidden email] >---
Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001 Basel
T +41 61 226 98 98, F +41 61 226 98 97
-----------------------------------------------< http://www.day.com >---

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Felix Meschberger-2
In reply to this post by Felix Meschberger-2
Hi all,

Am Montag, den 10.03.2008, 15:51 +0100 schrieb Felix Meschberger:
> Currently names used by Sling are prefixed with sling: with the
> exception of well known parameters of the ujax servlets. To get all
> these prefixes in line I suggest we change the prefix used by ujax
> parameters to sling:

Coming back to this and having had a prototype and a discussion with
Carsten, I clarify the changes as follows:

  * the client side library ujax.js will be renamed to sling.js. Any
    references to ujax in the library is replaced by Sling.
  * The Ujax* classes in the sling/ujax module are renamed to Sling*
  * The ujax package is of course renamed accordingly
  * The sling/ujax module is renamed to sling/servlets-post
  * The request parameter prefix ujax: is replaced by sling:post:
    (see below for reasonings)

Regarding the sling:post: prefix. This looks somewhat strange, correct.
The problem is, that we cannot just use "sling:" instead of ujax: as the
prefix because this prefix is also used for properties to be written
back. This would therefore lead to a collision in the parameter prefix
use. Of course I am open to using something else than sling:post: as
long as it makes sense and creates no collision which requires extensive
detection.

Comments ?

Regards
Felix


Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
+1

And also I really would like to see the name "Catapult" being used
somewhere in Sling, I don't think it makes sense to use it here. So lets
keep it for something better...

Carsten

Felix Meschberger wrote:

> Hi all,
>
> Am Montag, den 10.03.2008, 15:51 +0100 schrieb Felix Meschberger:
>> Currently names used by Sling are prefixed with sling: with the
>> exception of well known parameters of the ujax servlets. To get all
>> these prefixes in line I suggest we change the prefix used by ujax
>> parameters to sling:
>
> Coming back to this and having had a prototype and a discussion with
> Carsten, I clarify the changes as follows:
>
>   * the client side library ujax.js will be renamed to sling.js. Any
>     references to ujax in the library is replaced by Sling.
>   * The Ujax* classes in the sling/ujax module are renamed to Sling*
>   * The ujax package is of course renamed accordingly
>   * The sling/ujax module is renamed to sling/servlets-post
>   * The request parameter prefix ujax: is replaced by sling:post:
>     (see below for reasonings)
>
> Regarding the sling:post: prefix. This looks somewhat strange, correct.
> The problem is, that we cannot just use "sling:" instead of ujax: as the
> prefix because this prefix is also used for properties to be written
> back. This would therefore lead to a collision in the parameter prefix
> use. Of course I am open to using something else than sling:post: as
> long as it makes sense and creates no collision which requires extensive
> detection.
>
> Comments ?
>
> Regards
> Felix
>
>


--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
On Thu, Mar 27, 2008 at 3:18 PM, Carsten Ziegeler <[hidden email]> wrote:
> +1

+1 to the proposed changes as well, and I'd suggest using "sling
client library" as the name for what was ujax, for use in docs, etc.

> ... And also I really would like to see the name "Catapult" being used
>  somewhere in Sling, I don't think it makes sense to use it here. So lets
>  keep it for something better...

Catapult? Never heard that name before, but it sounds really cool ;-)

-Bertrand

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
Bertrand Delacretaz wrote:
> On Thu, Mar 27, 2008 at 3:18 PM, Carsten Ziegeler <[hidden email]> wrote:
>> +1
>
> +1 to the proposed changes as well, and I'd suggest using "sling
> client library" as the name for what was ujax, for use in docs, etc.
Hmm, I think if we use this in the docs, the module name should reflect
this.

>
>> ... And also I really would like to see the name "Catapult" being used
>>  somewhere in Sling, I don't think it makes sense to use it here. So lets
>>  keep it for something better...
>
> Catapult? Never heard that name before, but it sounds really cool ;-)
It might be that you never "heard" it before, but I guess you read it
somewhere :)

Carsten
--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Felix Meschberger-2
Hi,

Am Donnerstag, den 27.03.2008, 15:35 +0100 schrieb Carsten Ziegeler:
> Bertrand Delacretaz wrote:
> > On Thu, Mar 27, 2008 at 3:18 PM, Carsten Ziegeler <[hidden email]> wrote:
> >> +1
> >
> > +1 to the proposed changes as well, and I'd suggest using "sling
> > client library" as the name for what was ujax, for use in docs, etc.
> Hmm, I think if we use this in the docs, the module name should reflect
> this.

But then we should split what is now known as the sling/ujax module ?

The Sling Client Library is just a single file - ujax.js (or now
sling.js). Of course we may create single module for that, but I am not
sure, whether this is worth it.

Regards
Felix

>
> >
> >> ... And also I really would like to see the name "Catapult" being used
> >>  somewhere in Sling, I don't think it makes sense to use it here. So lets
> >>  keep it for something better...
> >
> > Catapult? Never heard that name before, but it sounds really cool ;-)
> It might be that you never "heard" it before, but I guess you read it
> somewhere :)
>
> Carsten


Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
Felix Meschberger wrote:

> Hi,
>
> Am Donnerstag, den 27.03.2008, 15:35 +0100 schrieb Carsten Ziegeler:
>> Bertrand Delacretaz wrote:
>>> On Thu, Mar 27, 2008 at 3:18 PM, Carsten Ziegeler <[hidden email]> wrote:
>>>> +1
>>> +1 to the proposed changes as well, and I'd suggest using "sling
>>> client library" as the name for what was ujax, for use in docs, etc.
>> Hmm, I think if we use this in the docs, the module name should reflect
>> this.
>
> But then we should split what is now known as the sling/ujax module ?
>
> The Sling Client Library is just a single file - ujax.js (or now
> sling.js). Of course we may create single module for that, but I am not
> sure, whether this is worth it.
>
Yepp, I share your feeling (that's why I said "if" :) ). I think we
should refer to the stuff what it is (atm): the post servlets.

Carsten

--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
In reply to this post by Felix Meschberger-2
On Thu, Mar 27, 2008 at 3:52 PM, Felix Meschberger <[hidden email]> wrote:

> ... The Sling Client Library is just a single file - ujax.js (or now
>  sling.js). Of course we may create single module for that, but I am not
>  sure, whether this is worth it....

I agree that this doesn't require a distinct module - calling sling.js
the "sling client library" is fine.

-Bertrand

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Tobias Bocanegra
In reply to this post by Felix Meschberger-2
>   * The Ujax* classes in the sling/ujax module are renamed to Sling*
so your saying:

o.a.s.ujax.impl.UjaxPostServlet -> o.a.s.servlets.post.SlingPostServlet
o.a.s.ujax.impl.UjaxPostProcesser -> o.a.s.servlets.post.SlingPostProcessor
...

could this not be moved to the org.apache.sling.servlets.defaults bundle?

>   * The request parameter prefix ujax: is replaced by sling:post:
>     (see below for reasonings)
>
>  Regarding the sling:post: prefix. This looks somewhat strange, correct.
>  The problem is, that we cannot just use "sling:" instead of ujax: as the
>  prefix because this prefix is also used for properties to be written
>  back. This would therefore lead to a collision in the parameter prefix
>  use. Of course I am open to using something else than sling:post: as
>  long as it makes sense and creates no collision which requires extensive
>  detection.
so a 'special' parameter would for example be:

      sling:postMoveSrc ?
or  sling:post:MoveSrc ?

this sounds weird, but ok for me :-)

regards,
--
Toby

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
Tobias Bocanegra wrote:
> so a 'special' parameter would for example be:
>
>       sling:postMoveSrc ?
> or  sling:post:MoveSrc ?
sling:post:MoveSrc

>
> this sounds weird, but ok for me :-)
>
Yepp, but it helps to avoid name clashes :)

Carsten

--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Felix Meschberger-2
In reply to this post by Tobias Bocanegra
Hi all,

Am Donnerstag, den 27.03.2008, 10:02 -0700 schrieb Tobias Bocanegra:
> >   * The Ujax* classes in the sling/ujax module are renamed to Sling*
> so your saying:
>
> o.a.s.ujax.impl.UjaxPostServlet -> o.a.s.servlets.post.SlingPostServlet
> o.a.s.ujax.impl.UjaxPostProcesser -> o.a.s.servlets.post.SlingPostProcessor
> ...
>
> could this not be moved to the org.apache.sling.servlets.defaults bundle?

Sounds reasonable, yes.

But then, what do we do with the client library ? We should probably
also move it. In fact, we may just merge the ujax module into the
servlets.default module.

OTOH by differentiating between read-access in the servlets.default and
write-access in the (current) ujax module we also simplify updates or
replacement of functionality. Not sure, whether this is enough to have
two modules.

Any more comments on this ?

>       sling:postMoveSrc ?
> or  sling:post:MoveSrc ?
>
> this sounds weird, but ok for me :-)

It may sound somewhat weird, but it makes sense: It is for sling - hence
sling: - it is for the post method - hence post: - and then comes the
command. It just one more level of namespacing.

Regards
Felix



Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
On Fri, Mar 28, 2008 at 8:25 AM, Felix Meschberger <[hidden email]> wrote:

> ... OTOH by differentiating between read-access in the servlets.default and
>  write-access in the (current) ujax module we also simplify updates or
>  replacement of functionality. Not sure, whether this is enough to have
>  two modules....

I'd like to keep this as two distinct bundles, to allow people to
remove one and keep the other.

I think the default GET servlets are of more general use than our POST
stuff which is very sling-specific - and nice, but people might want
to remove it depending on how their apps work.

-Bertrand

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Carsten Ziegeler
I think we should do this renaming asap. Do we already have a jira issue
for this?

Carsten

Bertrand Delacretaz wrote:

> On Fri, Mar 28, 2008 at 8:25 AM, Felix Meschberger <[hidden email]> wrote:
>
>> ... OTOH by differentiating between read-access in the servlets.default and
>>  write-access in the (current) ujax module we also simplify updates or
>>  replacement of functionality. Not sure, whether this is enough to have
>>  two modules....
>
> I'd like to keep this as two distinct bundles, to allow people to
> remove one and keep the other.
>
> I think the default GET servlets are of more general use than our POST
> stuff which is very sling-specific - and nice, but people might want
> to remove it depending on how their apps work.
>
> -Bertrand
>


--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Replace ujax: prefix to sling:

Bertrand Delacretaz
On Mon, Mar 31, 2008 at 11:32 AM, Carsten Ziegeler <[hidden email]> wrote:
> I think we should do this renaming asap. Do we already have a jira issue
>  for this?

Yes, https://issues.apache.org/jira/browse/SLING-326, but it needs to
be updated according to this thread.

-Bertrand

12