Unable to start o.a.sling.starter-10 with java 10

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to start o.a.sling.starter-10 with java 10

Eric Norman
Is anyone else having troubles with staring o.a.sling.starter-10 with a
java 10 JRE?  The release notes for sling 10 indicated that java 10 was
supported, but I get the following error when attempting to startup.  I get
now errors when using a java8 JRE.


~/Downloads $ /usr/lib/jvm/java-10-oracle/bin/java -jar
org.apache.sling.starter-10.jar
13.07.2018 17:34:57.052 *INFO * [main] Setting sling.home=sling (default)
13.07.2018 17:34:57.054 *INFO * [main] Starting Apache Sling in
/home/enorman/Downloads/sling
13.07.2018 17:34:57.056 *INFO * [main] Sling  Extension Lib Home :
/home/enorman/Downloads/sling/ext
13.07.2018 17:34:57.056 *INFO * [main] Checking launcher JAR in folder
/home/enorman/Downloads/sling
13.07.2018 17:34:57.077 *INFO * [main] Installing new launcher:
jar:file:/home/enorman/Downloads/org.apache.sling.starter-10.jar!/resources/org.apache.sling.launchpad.base.jar,
5.6.10.2_6_26 (org.apache.sling.launchpad.base.jar.1531528497077)
13.07.2018 17:34:57.079 *INFO * [main] Loading launcher class
org.apache.sling.launchpad.base.app.MainDelegate from
org.apache.sling.launchpad.base.jar.1531528497077
13.07.2018 17:34:57.080 *INFO * [main] External Libs Home (ext) is null or
does not exists.
13.07.2018 17:34:57.091 *INFO * [main] Setting
sling.launchpad=/home/enorman/Downloads/sling
13.07.2018 17:34:57.091 *INFO * [main] Starting launcher ...
13.07.2018 17:34:57.103 *INFO * [main] HTTP server port: 8080
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by
org.apache.felix.framework.ext.ClassPathExtenderFactory$DefaultClassLoaderExtender
(file:/home/enorman/Downloads/sling/org.apache.sling.launchpad.base.jar.1531528497077)
to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of
org.apache.felix.framework.ext.ClassPathExtenderFactory$DefaultClassLoaderExtender
WARNING: Use --illegal-access=warn to enable warnings of further illegal
reflective access operations
WARNING: All illegal access operations will be denied in a future release
13.07.2018 17:34:57.639 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error
starting slinginstall:org.apache.sling.installer.core-3.8.10.jar
(org.osgi.framework.BundleException: Unable to resolve
org.apache.sling.installer.core [2](R 2.0): missing requirement
[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
(osgi.wiring.package=javax.annotation) Unresolved requirements:
[[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
(osgi.wiring.package=javax.annotation)])
org.osgi.framework.BundleException: Unable to resolve
org.apache.sling.installer.core [2](R 2.0): missing requirement
[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
(osgi.wiring.package=javax.annotation) Unresolved requirements:
[[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
(osgi.wiring.package=javax.annotation)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.base/java.lang.Thread.run(Thread.java:844)


Regards,
Eric
Reply | Threaded
Open this post in threaded view
|

Re: Unable to start o.a.sling.starter-10 with java 10

Karl Pauls
can you try again with

java —add-modules java.se.ee

?

regards,

Karl

On Saturday, July 14, 2018, Eric Norman <[hidden email]> wrote:

> Is anyone else having troubles with staring o.a.sling.starter-10 with a
> java 10 JRE?  The release notes for sling 10 indicated that java 10 was
> supported, but I get the following error when attempting to startup.  I get
> now errors when using a java8 JRE.
>
>
> ~/Downloads $ /usr/lib/jvm/java-10-oracle/bin/java -jar
> org.apache.sling.starter-10.jar
> 13.07.2018 17:34:57.052 *INFO * [main] Setting sling.home=sling (default)
> 13.07.2018 17:34:57.054 *INFO * [main] Starting Apache Sling in
> /home/enorman/Downloads/sling
> 13.07.2018 17:34:57.056 *INFO * [main] Sling  Extension Lib Home :
> /home/enorman/Downloads/sling/ext
> 13.07.2018 17:34:57.056 *INFO * [main] Checking launcher JAR in folder
> /home/enorman/Downloads/sling
> 13.07.2018 17:34:57.077 *INFO * [main] Installing new launcher:
> jar:file:/home/enorman/Downloads/org.apache.sling.
> starter-10.jar!/resources/org.apache.sling.launchpad.base.jar,
> 5.6.10.2_6_26 (org.apache.sling.launchpad.base.jar.1531528497077)
> 13.07.2018 17:34:57.079 *INFO * [main] Loading launcher class
> org.apache.sling.launchpad.base.app.MainDelegate from
> org.apache.sling.launchpad.base.jar.1531528497077
> 13.07.2018 17:34:57.080 *INFO * [main] External Libs Home (ext) is null or
> does not exists.
> 13.07.2018 17:34:57.091 *INFO * [main] Setting
> sling.launchpad=/home/enorman/Downloads/sling
> 13.07.2018 17:34:57.091 *INFO * [main] Starting launcher ...
> 13.07.2018 17:34:57.103 *INFO * [main] HTTP server port: 8080
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by
> org.apache.felix.framework.ext.ClassPathExtenderFactory$
> DefaultClassLoaderExtender
> (file:/home/enorman/Downloads/sling/org.apache.sling.launchpad.base.jar.
> 1531528497077)
> to method java.net.URLClassLoader.addURL(java.net.URL)
> WARNING: Please consider reporting this to the maintainers of
> org.apache.felix.framework.ext.ClassPathExtenderFactory$
> DefaultClassLoaderExtender
> WARNING: Use --illegal-access=warn to enable warnings of further illegal
> reflective access operations
> WARNING: All illegal access operations will be denied in a future release
> 13.07.2018 17:34:57.639 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error
> starting slinginstall:org.apache.sling.installer.core-3.8.10.jar
> (org.osgi.framework.BundleException: Unable to resolve
> org.apache.sling.installer.core [2](R 2.0): missing requirement
> [org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> (osgi.wiring.package=javax.annotation) Unresolved requirements:
> [[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve
> org.apache.sling.installer.core [2](R 2.0): missing requirement
> [org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> (osgi.wiring.package=javax.annotation) Unresolved requirements:
> [[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> (osgi.wiring.package=javax.annotation)]
> at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
> at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
> at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
> at
> org.apache.felix.framework.FrameworkStartLevelImpl.run(
> FrameworkStartLevelImpl.java:308)
> at java.base/java.lang.Thread.run(Thread.java:844)
>
>
> Regards,
> Eric
>


--
Karl Pauls
[hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Unable to start o.a.sling.starter-10 with java 10

Eric Norman
Ah, ok.  Yes it does start with the --add-modules java.se.ee argument added.

On Sat, Jul 14, 2018 at 12:02 AM, Karl Pauls <[hidden email]> wrote:

> can you try again with
>
> java —add-modules java.se.ee
>
> ?
>
> regards,
>
> Karl
>
> On Saturday, July 14, 2018, Eric Norman <[hidden email]> wrote:
>
> > Is anyone else having troubles with staring o.a.sling.starter-10 with a
> > java 10 JRE?  The release notes for sling 10 indicated that java 10 was
> > supported, but I get the following error when attempting to startup.  I
> get
> > now errors when using a java8 JRE.
> >
> >
> > ~/Downloads $ /usr/lib/jvm/java-10-oracle/bin/java -jar
> > org.apache.sling.starter-10.jar
> > 13.07.2018 17:34:57.052 *INFO * [main] Setting sling.home=sling (default)
> > 13.07.2018 17:34:57.054 *INFO * [main] Starting Apache Sling in
> > /home/enorman/Downloads/sling
> > 13.07.2018 17:34:57.056 *INFO * [main] Sling  Extension Lib Home :
> > /home/enorman/Downloads/sling/ext
> > 13.07.2018 17:34:57.056 *INFO * [main] Checking launcher JAR in folder
> > /home/enorman/Downloads/sling
> > 13.07.2018 17:34:57.077 *INFO * [main] Installing new launcher:
> > jar:file:/home/enorman/Downloads/org.apache.sling.
> > starter-10.jar!/resources/org.apache.sling.launchpad.base.jar,
> > 5.6.10.2_6_26 (org.apache.sling.launchpad.base.jar.1531528497077)
> > 13.07.2018 17:34:57.079 *INFO * [main] Loading launcher class
> > org.apache.sling.launchpad.base.app.MainDelegate from
> > org.apache.sling.launchpad.base.jar.1531528497077
> > 13.07.2018 17:34:57.080 *INFO * [main] External Libs Home (ext) is null
> or
> > does not exists.
> > 13.07.2018 17:34:57.091 *INFO * [main] Setting
> > sling.launchpad=/home/enorman/Downloads/sling
> > 13.07.2018 17:34:57.091 *INFO * [main] Starting launcher ...
> > 13.07.2018 17:34:57.103 *INFO * [main] HTTP server port: 8080
> > WARNING: An illegal reflective access operation has occurred
> > WARNING: Illegal reflective access by
> > org.apache.felix.framework.ext.ClassPathExtenderFactory$
> > DefaultClassLoaderExtender
> > (file:/home/enorman/Downloads/sling/org.apache.sling.launchpad.base.jar.
> > 1531528497077)
> > to method java.net.URLClassLoader.addURL(java.net.URL)
> > WARNING: Please consider reporting this to the maintainers of
> > org.apache.felix.framework.ext.ClassPathExtenderFactory$
> > DefaultClassLoaderExtender
> > WARNING: Use --illegal-access=warn to enable warnings of further illegal
> > reflective access operations
> > WARNING: All illegal access operations will be denied in a future release
> > 13.07.2018 17:34:57.639 *ERROR* [FelixStartLevel] ERROR: Bundle '2' Error
> > starting slinginstall:org.apache.sling.installer.core-3.8.10.jar
> > (org.osgi.framework.BundleException: Unable to resolve
> > org.apache.sling.installer.core [2](R 2.0): missing requirement
> > [org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> > (osgi.wiring.package=javax.annotation) Unresolved requirements:
> > [[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> > (osgi.wiring.package=javax.annotation)])
> > org.osgi.framework.BundleException: Unable to resolve
> > org.apache.sling.installer.core [2](R 2.0): missing requirement
> > [org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> > (osgi.wiring.package=javax.annotation) Unresolved requirements:
> > [[org.apache.sling.installer.core [2](R 2.0)] osgi.wiring.package;
> > (osgi.wiring.package=javax.annotation)]
> > at org.apache.felix.framework.Felix.resolveBundleRevision(
> Felix.java:4149)
> > at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
> > at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
> > at
> > org.apache.felix.framework.FrameworkStartLevelImpl.run(
> > FrameworkStartLevelImpl.java:308)
> > at java.base/java.lang.Thread.run(Thread.java:844)
> >
> >
> > Regards,
> > Eric
> >
>
>
> --
> Karl Pauls
> [hidden email]
>