apache sling 9 and eclipse ide tooling

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

apache sling 9 and eclipse ide tooling

Ruben Reusser
Hi there,

I noticed that the eclipse ide tooling for AEM/sling installs 2 bundles

Apache Sling Tooling Support Install -
org.apache.sling.tooling.support.install (1.0.2)
Apache Sling Tooling Support Source -
org.apache.sling.tooling.support.source (1.0.0)

both these bundles seem to be in an installed state as they have a
dependency issue:
org.apache.sling.commons.json,version=[2.0,3) -- Cannot be resolved

I am using the AEM Developer Tools version 1.1.0

It seems older versions of the bundles are installed as there are newer
versions available as per [1]. Installing the never versions seems to
fix the issue.

Is there any plan to release a new version of the ide plugin? Not sure
if the older versions are used for backwards compatibility reasons with
older versions of sling/AEM.

Would be great to have a working version of the ide integration for the
latest release of sling/AEM.

thank you

Ruben

[1] https://sling.apache.org/downloads.cgi

Tooling Support Install 1.0.4 Bundle
<http://mirrors.sonic.net/apache/sling/org.apache.sling.tooling.support.install-1.0.4.jar>(asc
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.install-1.0.4.jar.asc>,md5
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.install-1.0.4.jar.md5>)
        Source ZIP
<http://mirrors.sonic.net/apache/sling/org.apache.sling.tooling.support.install-1.0.4-source-release.zip>(asc
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.install-1.0.4-source-release.zip.asc>,md5
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.install-1.0.4-source-release.zip.md5>)

Tooling Support Source 1.0.4 Bundle
<http://mirrors.sonic.net/apache/sling/org.apache.sling.tooling.support.source-1.0.4.jar>(asc
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.source-1.0.4.jar.asc>,md5
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.source-1.0.4.jar.md5>)
        Source ZIP
<http://mirrors.sonic.net/apache/sling/org.apache.sling.tooling.support.source-1.0.4-source-release.zip>(asc
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.source-1.0.4-source-release.zip.asc>,md5
<http://www.apache.org/dist/sling/org.apache.sling.tooling.support.source-1.0.4-source-release.zip.md5>)



Reply | Threaded
Open this post in threaded view
|

Re: apache sling 9 and eclipse ide tooling

Robert Munteanu-2
Hi Ruben,

On Thu, 2017-11-02 at 09:16 -0700, Ruben Reusser wrote:
> Is there any plan to release a new version of the ide plugin? Not
> sure
> if the older versions are used for backwards compatibility reasons
> with
> older versions of sling/AEM.
>
> Would be great to have a working version of the ide integration for
> the
> latest release of sling/AEM.

I plan to look into it this month, the release is blocked mainly by

  https://issues.apache.org/jira/browse/SLING-6585

Thanks,

Robert
Reply | Threaded
Open this post in threaded view
|

Re: apache sling 9 and eclipse ide tooling

Ruben Reusser
Robert,

thanks for the information. Looking forward to the next version

Ruben

On 2017-11-06 00:15, Robert Munteanu <[hidden email]> wrote:
 > Hi Ruben,>
 >
 > On Thu, 2017-11-02 at 09:16 -0700, Ruben Reusser wrote:>
 > > Is there any plan to release a new version of the ide plugin? Not>
 > > sure >
 > > if the older versions are used for backwards compatibility reasons>
 > > with >
 > > older versions of sling/AEM.>
 > > >
 > > Would be great to have a working version of the ide integration for>
 > > the >
 > > latest release of sling/AEM.>
 >
 > I plan to look into it this month, the release is blocked mainly by>
 >
 > https://issues.apache.org/jira/browse/SLING-6585>
 >
 > Thanks,>
 >
 > Robert>
 >