github samples w/ Sling 9

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

github samples w/ Sling 9

Mike Engelhart
Hi all -

I’m trying to run the samples here
https://github.com/apache/sling-samples <https://github.com/apache/sling-samples>

I built/deployed htlblog and slingbucks (for slingbucks I followed the instructions about anonymous access, etc) and they both  built and loaded properly but when I follow the links listed in the README’s I get the
Resource dumped by HtmlRendererServlet

message..

Do these not work properly with Sling 9?

Thanks for any info.

Mike
Reply | Threaded
Open this post in threaded view
|

Re: github samples w/ Sling 9

Robert Munteanu-2
Hi Mike,

On Sun, 2017-12-03 at 09:42 -0500, Mike Engelhart wrote:

> Hi all -
>
> I’m trying to run the samples here
> https://github.com/apache/sling-samples <https://github.com/apache/sl
> ing-samples>
>
> I built/deployed htlblog and slingbucks (for slingbucks I followed
> the instructions about anonymous access, etc) and they both  built
> and loaded properly but when I follow the links listed in the
> README’s I get the
> Resource dumped by HtmlRendererServlet
>
> message..
>
> Do these not work properly with Sling 9?

Indeed, these seem to be broken with both Sling 9 and Sling 10-
SNAPSHOT.

I don't have time right now to look into what is going on, but I filed

https://issues.apache.org/jira/browse/SLING-7308
https://issues.apache.org/jira/browse/SLING-7309

so that whenever someone has the time they can look into it.

Thanks,

Robert
Reply | Threaded
Open this post in threaded view
|

Re: github samples w/ Sling 9

chrismillar
Mike / Robert
This was a result of HTLBlog's initial content overwriting nodes in the
apps folder and breaking most resource rendering.

I'm not sure how initial content loading changed, but this was not an issue
with Sling 8.

I have raised a PR that fixes the issue, makes content loading more
specific, and updated the sample to now reflect that it works with Sling 9.

Let me know if you have any other issues.

https://github.com/apache/sling-samples/pull/1


On Wed, Dec 13, 2017 at 9:12 AM, Robert Munteanu <[hidden email]> wrote:

> Hi Mike,
>
> On Sun, 2017-12-03 at 09:42 -0500, Mike Engelhart wrote:
> > Hi all -
> >
> > I’m trying to run the samples here
> > https://github.com/apache/sling-samples <https://github.com/apache/sl
> > ing-samples>
> >
> > I built/deployed htlblog and slingbucks (for slingbucks I followed
> > the instructions about anonymous access, etc) and they both  built
> > and loaded properly but when I follow the links listed in the
> > README’s I get the
> > Resource dumped by HtmlRendererServlet
> >
> > message..
> >
> > Do these not work properly with Sling 9?
>
> Indeed, these seem to be broken with both Sling 9 and Sling 10-
> SNAPSHOT.
>
> I don't have time right now to look into what is going on, but I filed
>
> https://issues.apache.org/jira/browse/SLING-7308
> https://issues.apache.org/jira/browse/SLING-7309
>
> so that whenever someone has the time they can look into it.
>
> Thanks,
>
> Robert
>
Reply | Threaded
Open this post in threaded view
|

Re: github samples w/ Sling 9

Robert Munteanu-2
On Wed, 2017-12-13 at 15:40 -0700, Chris Millar wrote:

> Mike / Robert
> This was a result of HTLBlog's initial content overwriting nodes in
> the
> apps folder and breaking most resource rendering.
>
> I'm not sure how initial content loading changed, but this was not an
> issue
> with Sling 8.
>
> I have raised a PR that fixes the issue, makes content loading more
> specific, and updated the sample to now reflect that it works with
> Sling 9.
>
> Let me know if you have any other issues.
>
> https://github.com/apache/sling-samples/pull/1

That works for me, thanks!

Robert