[jira] Created: (SLING-326) Rename µjax to "sling client library"

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
Rename µjax to "sling client library"
-------------------------------------

                 Key: SLING-326
                 URL: https://issues.apache.org/jira/browse/SLING-326
             Project: Sling
          Issue Type: Improvement
            Reporter: Bertrand Delacretaz
            Priority: Minor


As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.

The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?

There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)

[1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)

    [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12578306#action_12578306 ]

Carsten Ziegeler commented on SLING-326:
----------------------------------------

I think we should also rename the "ujax:" prefix to "sling:" for the request parameters

Btw, the sling client library is one of the greatest things on earth, so it deserves the name catapult.

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Priority: Minor
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

Cute name for Sling Client Library: Catapult (Re: [jira] Commented: (SLING-326) Rename µjax to "sling client library")

Felix Meschberger-2
Hi all,

Once upon a time Carsten proposed "Catapult" when we were looking for a
name - it escapes my memory, what exactly it was ;-)

Now we are more closely integrating µjax into Sling as the Sling Client
Library. And of course, the famous "Catapult" is put back in action.

I would like to take this up and put it for discussion, that we
code-name the Sling Client Library as "Catapult".

Internally, we would still use sling: as prefix. But we might name the
client side java script file catapult.js...

WDYT ?

Regards
Felix


Reply | Threaded
Open this post in threaded view
|

Re: Cute name for Sling Client Library: Catapult (Re: [jira] Commented: (SLING-326) Rename µjax to "sling client library")

Carsten Ziegeler
Felix Meschberger wrote:

> Hi all,
>
> Once upon a time Carsten proposed "Catapult" when we were looking for a
> name - it escapes my memory, what exactly it was ;-)
>
> Now we are more closely integrating µjax into Sling as the Sling Client
> Library. And of course, the famous "Catapult" is put back in action.
>
> I would like to take this up and put it for discussion, that we
> code-name the Sling Client Library as "Catapult".
>
> Internally, we would still use sling: as prefix. But we might name the
> client side java script file catapult.js...
>
> WDYT ?
>
Juppy, yes, yes, yes, please :)

Big +1

Carsten

--
Carsten Ziegeler
[hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Cute name for Sling Client Library: Catapult (Re: [jira] Commented: (SLING-326) Rename µjax to "sling client library")

Peter Svensson
+1

On Fri, Mar 14, 2008 at 4:33 PM, Carsten Ziegeler <[hidden email]>
wrote:

> Felix Meschberger wrote:
> > Hi all,
> >
> > Once upon a time Carsten proposed "Catapult" when we were looking for a
> > name - it escapes my memory, what exactly it was ;-)
> >
> > Now we are more closely integrating µjax into Sling as the Sling Client
> > Library. And of course, the famous "Catapult" is put back in action.
> >
> > I would like to take this up and put it for discussion, that we
> > code-name the Sling Client Library as "Catapult".
> >
> > Internally, we would still use sling: as prefix. But we might name the
> > client side java script file catapult.js...
> >
> > WDYT ?
> >
> Juppy, yes, yes, yes, please :)
>
> Big +1
>
> Carsten
>
> --
> Carsten Ziegeler
> [hidden email]
>
Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler updated SLING-326:
-----------------------------------


The following is a list of changes as collected from the mailing list:
 * the client side library ujax.js will be renamed to sling.js. Any
    references to ujax in the library is replaced by Sling.
  * The Ujax* classes in the sling/ujax module are renamed to Sling*
  * The ujax package is of course renamed accordingly
  * The sling/ujax module is renamed to sling/servlets-post
  * The request parameter prefix ujax: is replaced by sling:post:

No renaming to Catapult or "Sling Client Library" as a name.

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Priority: Minor
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler updated SLING-326:
-----------------------------------

              Assignee: Carsten Ziegeler
    Remaining Estimate: 0h
     Original Estimate: 0h

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler updated SLING-326:
-----------------------------------


Renamed sling/ujax module to sling/servlets-post
Renamed /ujax/ujax.js to /sling/sling.js

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler updated SLING-326:
-----------------------------------


Renamed package to *.servlets.post.*
Renamed Ujax* classes to Sling*

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler updated SLING-326:
-----------------------------------


Renamed all references from ujax to sling.
There are some remaining items which will be discussed on the mailing list.

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Reply | Threaded
Open this post in threaded view
|

[jira] Closed: (SLING-326) Rename µjax to "sling client library"

Robert Munteanu (Jira)
In reply to this post by Robert Munteanu (Jira)

     [ https://issues.apache.org/jira/browse/SLING-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Carsten Ziegeler closed SLING-326.
----------------------------------

    Resolution: Fixed

Mounting sling info servlet at /system/sling/info
Renaming dojo-ujax to dojo-sling.

> Rename µjax to "sling client library"
> -------------------------------------
>
>                 Key: SLING-326
>                 URL: https://issues.apache.org/jira/browse/SLING-326
>             Project: Sling
>          Issue Type: Improvement
>            Reporter: Bertrand Delacretaz
>            Assignee: Carsten Ziegeler
>            Priority: Minor
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> As discussed recently [1], reducing the number of names for the different sling components should help people make sense of it.
> The idea is to rename the µjax stuff to "sling client library", and I suppose the UjaxPostServlet can be renamed to SlingPostServlet?
> There were some discussions about using "catapult" for the name, but that's so good a name that we'll keep it in store for later ;-)
> [1] http://markmail.org/message/5yeuwlbsj6m7da6o

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.