[jira] [Updated] (SLING-8627) Update sling-jcr-repoinit to Oak 1.16.0 and Jackrabbit 2.18.2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (SLING-8627) Update sling-jcr-repoinit to Oak 1.16.0 and Jackrabbit 2.18.2

Oliver Lietz (Jira)

     [ https://issues.apache.org/jira/browse/SLING-8627?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

angela updated SLING-8627:
--------------------------
    Attachment: SLING-8627.patch

> Update sling-jcr-repoinit to Oak 1.16.0 and Jackrabbit 2.18.2
> -------------------------------------------------------------
>
>                 Key: SLING-8627
>                 URL: https://issues.apache.org/jira/browse/SLING-8627
>             Project: Sling
>          Issue Type: Task
>          Components: Repoinit
>            Reporter: angela
>            Priority: Major
>         Attachments: SLING-8627.patch
>
>
> while working on the patch for SLING-8602 i noticed that the ITs are failing as soon as i update oak and jackrabbit version in _sling-jcr-repoinit_. i verified that by taking an unmodified checkout and just adjusting the the _oak.version_ and _jackrabbit.version_ properties.
> the issue is (up to now) two fold:
> # the embedded org.apache.jackrabbit bundles in _org.apache.sling.testing.sling-mock-oak_ (see SLING-8625) prevent the configured oak/jackrabbit versions to take effect
> # once that is fix, the ITs (setup configuration with launchpad 9) will fail
> the latter most likely require multiple changes
> - updating the _it-model.txt_ to list oak bundles in order to avoid unresolved oak dependencies
> - once that is solved the ITs fail with missing SlingRepository service and [~radu.cotescu] suspected that it might be required to additionally update _org.apache.sling.jcr.oak.server_ to oak 1.16.0. if that turns out to be needed i would cover it with another task.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)