org.apache.sling.commons.scheduler under Java 8

classic Classic list List threaded Threaded
5 messages Options
Mic
Reply | Threaded
Open this post in threaded view
|

org.apache.sling.commons.scheduler under Java 8

Mic
Hi guys,

i try to run org.apache.sling.commons.scheduler OSGi Bundle-Version: 2.4.14 under Java 8.
I got problems due the Bundle-RequiredExecutionEnvironment: JavaSE-1.6 / Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.6))"

There was no problem under Java 7.

Any ideas why?

Thanks a lot.

Best Regards,
Mic
Reply | Threaded
Open this post in threaded view
|

Re: org.apache.sling.commons.scheduler under Java 8

David Bosschaert
Hi Mic,

The osgi.ee capabilities are exposed by newer versions of Java if they were
compatible. So frameworks running under Java 7, Java 8 (and hopefully Java
9) will also expose the JavaSE capability version 1.6.

More background on this versioning concept which is applied to OSGi
'Portable Contracts' as well here:
https://www.osgi.org/portable-java-contract-definitions/

Best regards,

David

On 25 April 2017 at 12:38, Mic <[hidden email]> wrote:

> Hi guys,
>
> i try to run org.apache.sling.commons.scheduler OSGi Bundle-Version:
> 2.4.14
> under Java 8.
> I got problems due the Bundle-RequiredExecutionEnvironment: JavaSE-1.6 /
> Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.6))"
>
> There was no problem under Java 7.
>
> Any ideas why?
>
> Thanks a lot.
>
> Best Regards,
> Mic
>
>
>
> --
> View this message in context: http://apache-sling.73963.n3.
> nabble.com/org-apache-sling-commons-scheduler-under-Java-8-tp4072921.html
> Sent from the Sling - Users mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: org.apache.sling.commons.scheduler under Java 8

Carsten Ziegeler
The problem might be that the framework implementation you use does not
support Java 8, e.g. if you're using an older implementation.

Regards
Carsten

David Bosschaert wrote

> Hi Mic,
>
> The osgi.ee capabilities are exposed by newer versions of Java if they were
> compatible. So frameworks running under Java 7, Java 8 (and hopefully Java
> 9) will also expose the JavaSE capability version 1.6.
>
> More background on this versioning concept which is applied to OSGi
> 'Portable Contracts' as well here:
> https://www.osgi.org/portable-java-contract-definitions/
>
> Best regards,
>
> David
>
> On 25 April 2017 at 12:38, Mic <[hidden email]> wrote:
>
>> Hi guys,
>>
>> i try to run org.apache.sling.commons.scheduler OSGi Bundle-Version:
>> 2.4.14
>> under Java 8.
>> I got problems due the Bundle-RequiredExecutionEnvironment: JavaSE-1.6 /
>> Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.6))"
>>
>> There was no problem under Java 7.
>>
>> Any ideas why?
>>
>> Thanks a lot.
>>
>> Best Regards,
>> Mic
>>
>>
>>
>> --
>> View this message in context: http://apache-sling.73963.n3.
>> nabble.com/org-apache-sling-commons-scheduler-under-Java-8-tp4072921.html
>> Sent from the Sling - Users mailing list archive at Nabble.com.
>>
>


 

--
Carsten Ziegeler
Adobe Research Switzerland
[hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: org.apache.sling.commons.scheduler under Java 8

Karl Pauls
On Tue, Apr 25, 2017 at 2:02 PM, Carsten Ziegeler <[hidden email]> wrote:
> The problem might be that the framework implementation you use does not
> support Java 8, e.g. if you're using an older implementation.


Which (at least in the case of Felix), basically just means that it
doesn't have the required config.properties. So, if that is the case
you could either update to a newer version of Felix or try to use the
java.ee and package related properties of a newer felix version.

regards,

Karl

> Regards
> Carsten
>
> David Bosschaert wrote
>> Hi Mic,
>>
>> The osgi.ee capabilities are exposed by newer versions of Java if they were
>> compatible. So frameworks running under Java 7, Java 8 (and hopefully Java
>> 9) will also expose the JavaSE capability version 1.6.
>>
>> More background on this versioning concept which is applied to OSGi
>> 'Portable Contracts' as well here:
>> https://www.osgi.org/portable-java-contract-definitions/
>>
>> Best regards,
>>
>> David
>>
>> On 25 April 2017 at 12:38, Mic <[hidden email]> wrote:
>>
>>> Hi guys,
>>>
>>> i try to run org.apache.sling.commons.scheduler OSGi Bundle-Version:
>>> 2.4.14
>>> under Java 8.
>>> I got problems due the Bundle-RequiredExecutionEnvironment: JavaSE-1.6 /
>>> Require-Capability: osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.6))"
>>>
>>> There was no problem under Java 7.
>>>
>>> Any ideas why?
>>>
>>> Thanks a lot.
>>>
>>> Best Regards,
>>> Mic
>>>
>>>
>>>
>>> --
>>> View this message in context: http://apache-sling.73963.n3.
>>> nabble.com/org-apache-sling-commons-scheduler-under-Java-8-tp4072921.html
>>> Sent from the Sling - Users mailing list archive at Nabble.com.
>>>
>>
>
>
>
>
> --
> Carsten Ziegeler
> Adobe Research Switzerland
> [hidden email]



--
Karl Pauls
[hidden email]
Mic
Reply | Threaded
Open this post in threaded view
|

Re: org.apache.sling.commons.scheduler under Java 8

Mic
This post was updated on .
Hi guys,

thanks for you help. I think i found the correct settings.

Now i use the following additional settings:

org.osgi.framework.system.packages.extra=${jre-1.8}

org.osgi.framework.system.capabilities.extra=osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.6,1.7,1.8"

For now, the Applications starts and the Exception is gone, hope this was the correct way (without updating to a newer Version).

Any concerns about this settings?

Thanks a lot.

Best regards,
Mic